Download and Install LineageOS 16 on Nexus 9 – flounder

GCam Port | Google Camera APK v9.2 (May 2024) Forums Google Device Forums Nexus 9 – flounder Download and Install LineageOS 16 on Nexus 9 – flounder

Viewing 10 posts - 1 through 10 (of 26 total)
  • Author
    Posts
  • #44902
    Linux User
    Participant

    Hi shibaa987,

    I downloaded latest stock ROM for Nexus 9 WIFI which is 7.1.1 (N9F27M, Oct 2017)

    I tried the flash.bat which failed to complete so manually tried your steps

    I am sure the “fastboot flash bootloader bootloaderXXXXXXXX.img” command worked as the Nexus is reporting HBOOT-3.50.0.0143

    I ignored radio as I have no phone capability.

    However when I run “fastboot flash system system.img” it never completes ….. see cmd( DOS) extract below:

    Please note system.img is 1.5 GB and other numbers are 0.5 GB approx..

    Can I do anything to fix please ?

    Directory of C:\…..\volantis-n9f27m\image-volantis-n9f27m

    18/08/2018 20:39 <DIR> .
    18/08/2018 20:39 <DIR> ..
    18/08/2018 20:39 67 android-info.txt
    18/08/2018 20:39 8,829,440 boot.img
    18/08/2018 20:39 6,398,184 cache.img
    18/08/2018 20:39 11,459,072 recovery.img
    18/08/2018 20:39 1,523,831,228 system.img
    18/08/2018 20:39 128,370,260 vendor.img
    6 File(s) 1,678,888,251 bytes
    2 Dir(s) 384,290,828,288 bytes free

    C:\……….\image-volantis-n9f27m>fastboot flash system system.img
    target reported max download size of 518205818 bytes
    erasing ‘system’…
    OKAY [ 0.894s]
    sending sparse ‘system’ (478340 KB)…

    #53360
    Linux User
    Participant

    to fix ask passsword and encryption you need to edit fstab.flonder in this way

     

    /dev/block/platform/sdhci-tegra.3/by-name/UDA /data f2fs noatime,nosuid,nodev,errors=panic wait,check,latemount,encryptable=/dev/block/platform/sdhci-tegra.3/by-name/MD1
    /dev/block/platform/sdhci-tegra.3/by-name/UDA /data ext4 noatime,nosuid,nodev,nomblk_io_submit,errors=panic wait,check,latemount,encryptable=/dev/block/platform/sdhci-tegra.3/by-name/MD1

     

    you nedd to chage forceencrypt mount option on encryptable

     

    for hwcomposer issu i can check @HashBang can you cntact me on hangouts as davide.franzino@gmail.com ?

    #44936
    Linux User
    Participant

    update – I am now back to Stock Android 7.1.1 following advice from Shibaa987 on a related link above. I may reload linOS 15.1 shortly and will monitor linOS 16 development.
    Thanks

    #56240
    Linux User
    Participant

    new build with notification panel width and position is available here

     

    https://drive.google.com/file/d/1BcTV_YykMDda2Lrwe_ddoM3rXYhL0KPU

    #44484
    Linux User
    Participant

    After that there might be many changes, so it is always recommended to try with new TWRP.
    I see the new TWRP for Nexus 9 is somewhat 3.2.3-0 or so.

    #44813
    Linux User
    Participant

    I think the TWRP asks for the password because of encryption.
    I will give you more data on this.

    @cblx5

    You can either flash another ROM or you can go back to stock Nexus 9 FW by flashing the stock images:
    https://developers.google.com/android/images#volantis

    You can follow the following guide: How to flash Nexus stock firmware

    #44405
    Linux User
    Participant

    Hi,

    Just tried this ROM ( from flounder 15.1 ) and it reports ERROR 7 while installing.

    Any tips?

    Thanks

    #49076
    Linux User
    Participant

    Do not use this image! It’s broken. To all effects, the touchscreen driver doesn’t work and there are rendering issues, that leaves the device useless. For the encryption problems, the only workaround is doing a factory reset on TWRP *but* be careful, that will delete your images as well.

    If you find yourself with a blank device (all but TWRP, like @cblx5) follow these steps:

    – Activate ADB Sideload on TWRP
    – Confirm that the device appears in ADB
    – Deactivate ADB Sideload
    – Use ADB to copy a new ROM onto the device to flash.

    That should do the trick.

    #44472
    Linux User
    Participant

    It could just be a TWRP issue.
    Can you tell me what is the TWRP version are you using and is it an OFFICIAL or unofficial TWRP build?

    #44483
    Linux User
    Participant

    Hi,

    Its TWRP 3.0.2-1 and I assume it is official, I just downloaded it from the TWRP list and was the latest at the time about a year ago. I have installed most Lineage 15.1 ROMs with it.

    After wiping all but “Internal Storage”, I then proceed to install the ROM and get ERROR 7 within a few seconds.

    Thanks

Viewing 10 posts - 1 through 10 (of 26 total)
  • You must be logged in to reply to this topic.

1 thought on “Download and Install LineageOS 16 on Nexus 9 – flounder”