LineageOS 14.1 for Xperia Tablet Z Nougat 7.1 ROM

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #15401
    Linux User

    Here comes the LineageOS 14.1 for Xperia Tablet Z (GSM, Wifi) via an unofficial build. In addition to this we have the CM14.1 Nougat ROM for Xperia Tablet Z. If you want the OFFICIAL update or some more Lineage ROMs then stay tuned to the LineageOS 14.1 Devices list page. This Xperia Tablet Z LineageOS 14.1 (pollux, pollux_windy) is brought to you by CaHbKaUp

    THIS IS AN INITIAL BUILD WHICH MAY NOT BOOT AT ALL OR EVEN IF IT BOOTS IT MAY HAVE MANY BUGS. HAVE A BACKUP OF THE CURRENT ROM BEFORE FLASHING THIS ROM AND TRY AT YOUR OWN RISK. Installing a custom ROM on a Xperia Tablet Z (pollux, pollux_windy) requires the bootloader to be unlocked on the Xperia Tablet Z (pollux, pollux_windy) phone, which may VOID your warranty and may delete all your data. Before proceeding further you may consider backup all data on the phone. You are the only person doing changes to your phone and I cannot be held responsible for the mistakes done by you.

    Status of LineageOS 14.1 for Xperia Tablet Z (GSM, Wifi), Nougat 7.1 ROM:

    – As per Santiago’s comment everything seems to be working well on the ROM by TeamButter
    – Not Known


    LineageOS 14.1 for Xperia Tablet Z (GSM, Wifi)


    Root binary is NOT inbuilt in LineageOS 14.1, so you may need a separate SuperSu package or LineageOS su binary to install to gain ROOT access. Here is How to ROOT LineageOS 14.1
    If there is no in-built ROOT or it does not work for some reason then you can try flashing SuperSU zip using recovery to gain ROOT access.


    1. Follow this if you are flashing LineageOS 14.1 for Xperia Tablet Z (pollux, pollux_windy) for the first time, or coming from another ROM:

      Points to NOTE:
      – Try to avoid restoring apps backup using Titanium Backup. It may break things up.
      – Don’t restore system data using Titanium Backup! It will definitely break the current installation.
      – It is also discouraged to Restoring Apps + Data using Titanium Backup.

    2. Upgrading from earlier version of LineageOS 14.1 for Xperia Tablet Z (pollux, pollux_windy):

    Complete the initial setup and enjoy Android Nougat 7.1 with LineageOS 14.1 for Xperia Tablet Z (pollux, pollux_windy). After the installation of Xperia Tablet Z LineageOS 14.1 (pollux, pollux_windy) you may want to enable ROOT access on your phone and here is how you can do that:
    How to Enable ROOT on LineageOS 14.1.

    Stay tuned or Subscribe to the Xperia Tablet Z (pollux, pollux_windy) forum For other Android Nougat ROMs, LineageOS 14.1 ROMs, other ROMs and all other device specific topics.
    Linux User

    I’m having trouble with the install of The install itself seems to run fine, but when I start up, it doesn’t ask for a WiFi connection, and therefor cannot get past either the screen which prompts where I want to “Bring your data from…” or if I press set up as new, I’ll get “Setup Wizard has stopped”. This will repeat no matter how many times I let it restart and go through again. I’ve tried it multiple times with either,, or

    I haven’t installed any previous versions of Lineage 14.1, and when I did try to install a previous version, it wouldn’t let me because I had installed this one (no matter which partitions I wiped System, cache, data, and Dalvik Cache).

    Linux User

    I don’t believe that even after wiping everything you are unable to flash a new ROM.
    The wiping might not have completed successfully. Or the TWRP might be problematic in this case.

    Can you clean the /system, then re-mount it and see if you have some content on it???

    Basically this will prove that the /system partition is not wiped if you find some content in the partition.

    If that is the case then I will suggest you to try with some other recovery version !!

    Linux User

    the /system directory is clean, but the root directory isn’t, does the /system partition consist solely of the /system directory? should I also be wiping Internal Storage (and would that even do anything about this problem)?

    Linux User

    Update: I was able to go back to CM 12.1, then install (which had a much higher download count). This version did prompt me for a WiFi connection, and worked fine. I would suggest developers look at the initial installation of the most recent patches, and ensure the WiFi connection works on startup after initial installation.

    Linux User

    Thanks @stevenas for the update.

    So updating the LineageOS 14.1 ROM on top of CM12.1 fixed the issue, is it?
    If yes then this will be a good information for those facing similar issue.

    Linux User

    Wiping and Updating to a previous major version (in my case I had 12.1) allowed me to then update to a previous version of 14.1 (after full wipe). Updating to the March 16 2017 version of 14.1 allowed me to get through the initial setup, and actually get it running, then I was able to update on top of that (with no wipes) to the current version.

    Linux User

    Good to know that you are running the latest Lineage OS. And yet again thanks for the detailed information.

    Linux User

    Excellent. Thank you. Any easy update from CM13. FYI it finished the lineage install with “E: unknown command. log” (or something like that) twice, before starting to install gapps; but it doesn’t seem to have caused any problems. Even the camera works properly now.


    After flash this ROM on my sony tablet z (pollux_windy SGP311), with previous android 5.1 and dual recovery, i was impressed with the quality and performance from my tablet.It’s everything working on perfection, but i have a problem cannot solve and i lost many hours to work with kernels, extractions, boot images, etc. The problem is the offline charge.When turn off the tablet and connect to charge, the tablet boots itself.If i look to led notifications, the sequence is that:
    1-Connect charge (red led)
    2-The led remains red and logo sony xperia appears
    3-The led change to violet (like when enter in TWRP)
    4-Led turn yellow and tablet boots.
    After read articles about the structure of original tft files from sony and the actual zip from Lineage i see a boot.img and not a kernel.sin or else, the all structure of files and mount are diferent.If you have a tip i apreciate. Best Regards.Thank you. Antonio Dinis from Portugal.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.