LineageOS 14.1 for Galaxy Tab 4 10.1 WiFi Android 7.1 ROM

Viewing 10 posts - 1 through 10 (of 11 total)
  • Author
  • #76260
    Linux User

    Thank you @siba for the quick reply. So I downloaded the 2018-08-12 version at

    The good news is voice recording is now working. Camera and the charging is still broke. For Camera I now get the error “Media server died”.

    Linux User

    Android Nougat 7.1 ROM, LineageOS 14.1 for Galaxy Tab 4 10.1 WiFi has now arrived via an UNOFFICIAL build. This Galaxy Tab 4 10.1 WiFi LineageOS 14.1 is brought to you by developer thisisapoorusernamechoice and another build is by gpancot.

    If you want some more LineageOS ROMs or wanna taste the OFFICIAL LineageOS build then stay tuned to the LineageOS 14.1 ROM collection page. Or if you are looking for other Nougat ROMs, then here is the CM14.1 for Galaxy Tab 4 10.1 WiFi.

    THIS IS AN INITIAL BUILD WHICH MAY HAVE MANY MORE BUGS THAN YOU CAN IMAGINE. HAVE A BACKUP BEFORE FLASHING THIS AND TRY AT YOUR OWN RISK. Installing a custom ROM on a Galaxy Tab 4 10.1 WiFi (matissewifi) may require the bootloader to be unlocked, which may VOID your warranty and may delete all your data. Before proceeding further you may consider backup all data on the phone. You are the only person doing changes to your phone and I cannot be held responsible for the mistakes done by you.

    Status of LineageOS 14.1 for Galaxy Tab 4 10.1 WiFi (matissewifi) Nougat 7.1 ROM:

    – Not Known
    – Not Known


    LineageOS 14.1 for Galaxy Tab 4 10.1 WiFi (matissewifi)

    REQUIRED LINKS AND FILES FOR LineageOS 14.1 for Galaxy Tab 4 10.1 WiFi NOUGAT 7.1 BASED CUSTOM ROM:

    Root binary is NOT inbuilt in LineageOS 14.1, so you may need a separate SuperSu package or LineageOS su binary to install to gain ROOT access. Here is How to Enable ROOT on LineageOS 14.1
    If there is no in-built ROOT or it does not work for some reason then you can try flashing SuperSU zip using recovery to gain ROOT access.


    1. Follow this if you are flashing LineageOS 14.1 for Galaxy Tab 4 10.1 WiFi (matissewifi) for the first time, or coming from another ROM:

      Points to NOTE:
      – Try to avoid restoring apps backup using Titanium Backup. It may break things up.
      – Don’t restore system data using Titanium Backup! It will definitely break the current installation.
      – It is also discouraged to Restoring Apps + Data using Titanium Backup.

    2. Upgrading from earlier version of Galaxy Tab 4 10.1 WiFi LineageOS 14.1 (matissewifi):

    Complete the initial setup and enjoy Android Nougat 7.1 with LineageOS 14.1 for Galaxy Tab 4 10.1 WiFi (matissewifi). After the installation of Galaxy Tab 4 10.1 WiFi LineageOS 14.1 ROM (matissewifi) you may want to enable ROOT access on your phone and here is how you can do that:
    How to Enable ROOT on LineageOS 14.1.

    Stay tuned or Subscribe to the Galaxy Tab 4 10.1 WiFi (matissewifi) forum For other Android Nougat ROMs, LineageOS 14.1 ROMs, other ROMs and all other device specific topics.


    Linux User

    So it seems this 14.1 rom has been downloaded 1200 times. Anyone care to give feedback? Is it usable? Any newer signs of an official rom on the horizon?

    My set-up is still back at android 4.4.2 (have worked on getting tarp onto it, and getting it rooted, but that not quite there, and newly available Ota updates being refused due to this) so I’m keen to get the whole los thing sorted.

    Also not sure if there is a more specific Los site to look into this. Google group seems to send me back to this cm site with the text all targeting Los, but it’s looking slightly stale.


    Linux User

    I also have same problems. Here is the list of issues

    1) Camera not working.

    2) Sound option in settings crashing

    3) Could not charge the device while it is powered off (Or if it is charging then there is no display of battery status when powered off)

    4) Bluetooth is not 100% accurate

    5) GPS is not 100% accurate

    Linux User

    I have similar problem as ahmedrafiq. Camera and sound recording doesn’t work. When powered off and charging, I get the charge icon, but I think it gets hung. I then have to hard reboot to use again. Didn’t test Bluetooth and GPS. I am using 2018 v. But….I am not much bothered about the bugs, not using those features anyway. I am happy that the tab got upgraded (Samsung told they are no more issuing any more updates) from Android 5.1 (almost unusable state…System UI error and other issues) to 7.1. Maybe I can use it a couple more years.


    @minty95 Thank you for the link. I have updated that on the main downloads section.
    The new build came on 29th August 2018.

    I have added a new build file of Lineage OS 14.1 for the tab built by gpancot.
    As reported by @minty95 this is more stable than the other.
    You can try this one and let us know how this goes on your device !

    Linux User

    Mod please remove previous post (and this new one), since I can’t edit it. (Since the stars have now aligned, and I’ve found all the useful threads over @

    Linux User

    This lineage doesn’t work, you’ll get an error message when starting and will be stuck in boot with KERNEL IS NOT SEANDROID ENFORCING

    If you flash the :
    I found it at

    This will still give you the same error kernel message but will continue and boot into Lineage, and it works pretty good as well

    Now just to find out how to get rid of the annoying kernel message when you boot the tablet

    Linux User

    I’ve tried this update a few times, but keep getting the dreaded “KERNEL IS NOT SEANDROID ENFORCING” after installing Lineage OS ( from here) and GApps ( I only have Linux or OS X, so Odin ( doesn’t work (and JOdin3 does nothing when it says “running”) and I’ve been using Heimdall per the instructions (fastboot

    I’ve tried both the instructions here and (where I started, then found this thread after the Heimdall said the n1awifi does not support my hardware: Samsung Galaxy Tab 4 10.1 SM-T530NU).

    I tried both the twrp-3.0.3-0_matisse_20170122-0641.img linked here and the latest twrp-3.1.0-0-matisse.img from the TWRP website (, with the same effect. Luckily I took a full backup and restoring the prior OS (Android 5.0.2) via TWRP recovery works. I was unable to find an “OEM Unlock” option in the Developer settings of the OEM provided Android OS and “fastboot oem unlock” just says “waiting for device” and “fastboot devices) says no devices when in OEM OS, Download mode, or Recovery mode.

    EDIT1: I should note that the “KERNEL IS NOT SEANDROID ENFORCING” should not be an issue (per, but this is where my device is stuck after flashing this Lineage OS 14.1 image.

    • This reply was modified 1 month, 1 week ago by Linux User.
    Linux User


    i had the same problem like Eric with the release 20170319. It ends into a bootloop.

    I took the older release 20170122 and it works fine. I get the message “KERNEL IS NOT SEANDROID ENFORCING” too by starting the device but the system works fine.

    Note: Made it with Odin under Windows 10.

Viewing 10 posts - 1 through 10 (of 11 total)
  • You must be logged in to reply to this topic.