LineageOS 14.1 for Galaxy S3 LTE (i9305) Nougat ROM

GCam Port | Google Camera APK v9.2 (April 2024) Forums Samsung Device Forums Galaxy S3 LTE – i9305 LineageOS 14.1 for Galaxy S3 LTE (i9305) Nougat ROM

Viewing 10 posts - 1 through 10 (of 11 total)
  • Author
  • #16518
    Linux User

    Android Nougat 7.1 ROM, LineageOS 14.1 for Galaxy S3 LTE has now arrived via an OFFICIAL build. If you want some more LineageOS ROMs then stay tuned to the LineageOS 14.1 ROM Devices list page. This Galaxy S3 LTE LineageOS 14.1 is an OFFICIAL LineageOS for Galaxy S3 LTE, which means you will be getting weekly updates of this ROM for your device.

    HAVE A BACKUP BEFORE FLASHING THIS AND TRY AT YOUR OWN RISK. Installing a custom ROM on a Galaxy S3 LTE (i9305) may require the bootloader to be unlocked, which may VOID your warranty and may delete all your data. Before proceeding further you may consider backup all data on the phone. You are the only person doing changes to your phone and I cannot be held responsible for the mistakes done by you.

    Status of LineageOS 14.1 for Galaxy S3 LTE (i9305) Nougat 7.1 ROM:

    – Not Known
    – Not Known


    LineageOS 14.1 for Galaxy S3 LTE (i9305)


    Root binary is NOT inbuilt in LineageOS 14.1, so you may need a separate SuperSu package or LineageOS su binary to install to gain ROOT access. Here is How to Enable ROOT on LineageOS 14.1
    If there is no in-built ROOT or it does not work for some reason then you can try flashing SuperSU zip using recovery to gain ROOT access.


    1. Follow this if you are flashing LineageOS 14.1 for Galaxy S3 LTE (i9305) for the first time, or coming from another ROM:

      Points to NOTE:
      – Try to avoid restoring apps backup using Titanium Backup. It may break things up.
      – Don’t restore system data using Titanium Backup! It will definitely break the current installation.
      – It is also discouraged to Restoring Apps + Data using Titanium Backup.

    2. Upgrading from earlier version of Galaxy S3 LTE LineageOS 14.1 (i9305):

    Complete the initial setup and enjoy Android Nougat 7.1 with LineageOS 14.1 for Galaxy S3 LTE (i9305). After the installation of Galaxy S3 LTE LineageOS 14.1 ROM (i9305) you may want to enable ROOT access on your phone and here is how you can do that:
    How to Enable ROOT on LineageOS 14.1.

    Stay tuned or Subscribe to the Galaxy S3 LTE (i9305) forum For other Android Nougat ROMs, LineageOS 14.1 ROMs, other ROMs and all other device specific topics.


    Linux User

    Wifi is not working . Saved but not connecting .

    Linux User

    Installed on my S3 LTE i9305 successfully, everything is working except sim card :/
    I am using Telenor sim in Pakistan and sim is not working. So please fix this bug soon and remind me to download the new update.
    Overall great work, Thanks but this time going back to UnOfficial Marshmallow.

    Linux User

    Dear Dev team,
    I too having the same issue – SIM not working, I changed couple of sims but still not working.
    Can you please fix it when you get time.

    I am waiting for this fix or Lineage 15 for i9305.

    Thanks for your great efforts on doing this.


    Linux User

    I have some random reboot (hardware) mainly on audio streaming (sometime, one very 10 minutes), never on the wifi link. attached is my last_kmsg with a kernel panic

    <Kernel panic – not syncing: subsystem_restart_wq_func[e56ff5e0]: Failed to powerup external_modem!>
    I tried several recoveries (full clean), without success

    Does anyone have an idea ?

    Really great work, thanks

    Linux User

    Hi @gulliver423 Your upload has not come. Try uploading once again.

    And this seems to be a kernel BUG and hence will not help you in anyway by changing the recovery or anything else.

    Also, give me all details of the ROM version used, date of the NIGHTLY build, recovery version used etc. so that I can raise a BUG to the LineageOS team on this.

    Linux User

    Hi shibaa987

    Recovery TWRP
    ROM Lineage
    KERNEL m3xx/m3:4.4.4/KTU84P/I9305XXUFPB1

    My last_kmsg if attached file is out

    <6>[ 199.807734] c0 call_battery_notify : VID : 0x1d6b, PID : 0x1 skipped.
    <7>[ 199.814150] c0 usb usb2: usb_probe_device
    <7>[ 199.814242] c0 usb usb2: configuration #1 chosen from 1 choice
    <7>[ 199.814731] c0 usb usb2: adding 2-0:1.0 (config #1, interface 0)
    <7>[ 199.817143] c0 hub 2-0:1.0: usb_probe_interface
    <7>[ 199.817234] c0 hub 2-0:1.0: usb_probe_interface – got id
    <6>[ 199.817341] c0 hub 2-0:1.0: USB hub found
    <6>[ 199.817448] c0 hub 2-0:1.0: 3 ports detected
    <7>[ 199.817528] c0 hub 2-0:1.0: standalone hub
    <7>[ 199.817602] c0 hub 2-0:1.0: no power switching (usb 1.0)
    <7>[ 199.817694] c0 hub 2-0:1.0: global over-current protection
    <7>[ 199.817790] c0 hub 2-0:1.0: power on to power good time: 4ms
    <7>[ 199.817910] c0 hub 2-0:1.0: local power source is good
    <7>[ 199.818000] c0 hub 2-0:1.0: no over-current condition exists
    <7>[ 199.818100] c0 hub 2-0:1.0: trying to enable port power on non-switchable hub
    <7>[ 199.825267] c0 s5p-ehci s5p-ehci: GetStatus port:2 status 001803 0 ACK POWER sig=j CSC CONNECT
    <7>[ 199.825428] c0 hub 1-0:1.0: port 2: status 0501 change 0001
    <7>[ 199.915243] c0 hub 2-0:1.0: state 7 ports 3 chg 0000 evt 0000
    <7>[ 199.925436] c0 hub 1-0:1.0: state 7 ports 3 chg 0004 evt 0000
    <7>[ 199.925577] c0 hub 1-0:1.0: port 2, status 0501, change 0000, 480 Mb/s
    <7>[ 199.980305] c0 s5p-ehci s5p-ehci: port 2 high speed
    <7>[ 199.980420] c0 s5p-ehci s5p-ehci: GetStatus port:2 status 001005 0 ACK POWER sig=se0 PE CONNECT
    <6>[ 200.040206] c0 usb 1-2: new high speed USB device number 2 using s5p-ehci
    <6>[ 200.210119] c0 mdm_subsys_powerup: mdm modem restart timed out.
    <0>[ 200.210250] c0 Kernel panic – not syncing: subsystem_restart_wq_func[e56ff5e0]: Failed to powerup external_modem!
    <4>[ 200.210448] c0 Backtrace:
    <4>[ 200.210568] c0 [<c005322c>] (dump_backtrace+0x0/0x120) from [<c07783c4>] (dump_stack+0x20/0x24)
    <4>[ 200.210711] c0 r7:e5734000 r6:c02d3e18 r5:c0778ad4 r4:c0c094a8
    <4>[ 200.210844] c0 [<c07783a4>] (dump_stack+0x0/0x24) from [<c077897c>] (panic+0xac/0x204)
    <4>[ 200.211003] c0 [<c07788d0>] (panic+0x0/0x204) from [<c0075f60>] (subsystem_restart_wq_func+0x2dc/0x2e0)
    <4>[ 200.211154] c0 r3:c09a97a8 r2:e56ff5e0 r1:c0789500 r0:c09aa2f4
    <4>[ 200.211271] c0 r7:e5734000
    <4>[ 200.211349] c0 [<c0075c84>] (subsystem_restart_wq_func+0x0/0x2e0) from [<c00bf73c>] (process_one_work+0x168/0x558)
    <4>[ 200.211528] c0 [<c00bf5d4>] (process_one_work+0x0/0x558) from [<c00bff20>] (worker_thread+0x178/0x410)
    <4>[ 200.211697] c0 [<c00bfda8>] (worker_thread+0x0/0x410) from [<c00c4e14>] (kthread+0xb0/0xb4)
    <4>[ 200.211882] c0 [<c00c4d64>] (kthread+0x0/0xb4) from [<c00a3d18>] (do_exit+0x0/0x92c)
    <4>[ 200.212011] c0 r6:c00a3d18 r5:c00c4d64 r4:eb057e88
    <6>[ 200.312538] c0 notifier_call_chain : NOTIFY BAD sec_debug_panic_handler
    <0>[ 200.312660] c0 Rebooting in 1 seconds..
    <7>[ 201.020055] c0 s5p-ohci s5p-ohci: auto-stop root hub
    <0>[ 201.314555] c0 sec_reboot (104, emergency)

    Samsung S-Boot 4.0 for GT-I9305 (Sep 12 2014 – 13:40:58)

    EXYNOS4412(EVT 1.1) / 2044MB / 0MB / Rev 2 / I9305XXUFNI3 /(PKG_ID 0xe074018)


    PMIC rev = PASS2(4)
    BUCK1OUT(vdd_mif) = 0x03
    BUCK3DVS1(vdd_int) = 0x28
    cardtype: 0x00000007
    mmc->card_caps: 0x00000311
    mmc->host_caps: 0x00000311
    [mmc] capacity = 30777344


    – read_bl1
    pit_check_signature (PIT) valid.
    initialize_ddi_data: usable! (5:0xe)
    [RPMB] emmc_rpmb_open:
    Get DATA success.

    [RPMB] emmc_rpmb_close:
    initialize_rpmb_data: usable! (GT-I9305:VERSION_-+A3)
    set_charger_current: chg curr(bf), in curr(17)
    set_charger_state: buck(1), chg(1), reg(0x05)
    microusb_get_attached_device: STATUS1:0x3f, 2:0x00
    set_auto_current: ta_state(0), curr(700)
    init_fuelgauge: fuelgauge power ok
    init_fuelgauge: not POR status
    init_fuelgauge: is reset case, skip soc-cal.
    get_table_soc: vcell(4001) is caculated to t-soc(77.927)
    init_fuelgauge: start: vcell(4001), vfocv(4056), soc(76), table soc(77)
    init_fuelgauge: finish: vcell(4001), vfocv(4056), soc(76), table soc(77)
    init_microusb_ic: before MUIC: CDETCTRL:0x2d
    init_microusb_ic: after MUIC: CDETCTRL:0x2d
    init_microusb_ic: MUIC: CONTROL1:0x00
    init_microusb_ic: MUIC: CONTROL1:0x00
    init_microusb_ic: MUIC: CONTROL2:0x3b
    init_microusb_ic: MUIC: CONTROL2:0x3b
    PMIC_ID = 0x02
    PMIC_IRQSRC = 0x00
    PMIC_IRQ1 = 0x00
    PMIC_IRQ2 = 0x00
    PMIC_IRQ1M = 0xff
    PMIC_IRQ2M = 0xff
    PMIC_STATUS1 = 0x12
    PMIC_STATUS2 = 0x00
    PMIC_PWRON = 0x09
    PMIC_RTCINT = 0x11
    PMIC_RTCINTM = 0x3f
    s5p_check_keypad: 0x0
    s5p_check_reboot_mode: INFORM3 = 0 … skip
    s5p_check_upload: MAGIC(0x66262564), RST_STAT(0x20000000)
    s5p_check_upload: debug level is 4f4c!
    s5p_check_upload: level low or unknown: skip 0
    s5p_check_download: 0
    microusb_get_attached_device: STATUS1:0x3f, 2:0x00
    check_pm_status: normal reset, do not enter LPM mode.
    cmu_div:1, div:7, src_clk:800000000, pixel_clk:38102400
    s5p_dsim_display_config: VIDEO MODE
    a2, 60, 90,
    <start_checksum:481>CHECKSUM_HEADER_SECTOR :4096
    <start_checksum:483>offset:50, size:6296
    <start_checksum:485>CHECKSUM_HEADER_INFO : NeedChecksum:0 PartNo:20
    Not Need Movinand Checksum
    Movinand Checksum Confirmation Pass
    [mobi_drv] add: 0x43e52500, size: 3933
    MobiCore INIT response = 0
    MobiCore RTM has initialized!
    MobiCore IDLE flag = 0
    MobiCore driver address 43e52500, size = 3933
    MobiCore RTM Notified back!
    MobiCore Driver loaded and RTM IDLE!
    MobiCore RTM has been uninitialized!
    load_kernel: loading boot image from 106496..
    Verify_Binary_Signature: failed.
    pit_check_signature (BOOT) invalid.
    Set invalid sign flag
    No need to update kernel type.

    SMC Num = 0x83000001

    mobismc success!!! [ret = 0]
    [s5p_check_sboot_version_rpmb]cur_version:VERSION_-+A3, rpmb_version:VERSION_-+A3
    rpmb_version:51, cur_version:51
    ATAG_CORE: 5 54410001 0 0 0
    ATAG_MEM: 4 54410002 20000000 40000000
    ATAG_MEM: 4 54410002 20000000 60000000
    ATAG_MEM: 4 54410002 20000000 80000000
    ATAG_MEM: 4 54410002 1FC00000 A0000000
    ATAG_SERIAL: 4 54410006 42f7a405 d6089f8d
    ATAG_INITRD2: 4 54420005 42000000 163c82
    ATAG_REVISION: 3 54410007 2
    check_rustproof [0]
    ATAG_CMDLINE: b1 54410009 ‘console=ram loglevel=4 androidboot.baseband=mdm sec_debug.level=0 sec_watchdog.sec_pet=5 androidboot.debug_level=0x4f4c sec_log=0x200000@0x46000000 sec_tima_log=0x200000@0x46202000 sec_avc_log=0x40000@0x46404000 s3cfb.bootloaderfb=0x5ec00000 lcdtype=96 consoleblank=0 lpj=3981312 vmalloc=176m oops=panic pmic_info=67 cordon=a9e8b102ee79091bce1a37f9ebc7c99d connie=GT-I9305_OPEN_EUR_c83922bf5d8c0260508331b814394821 androidboot.emmc_checksum=3 androidboot.boot_salescode= androidboot.odin_download=1 androidboot.bootloader=I9305XXUFNI3 androidboot.selinux=enforcing androidboot.warranty_bit=1 androidboot.sec_atd.tty=/dev/ttySAC2 androidboot.serialno=42f7a405d6089f8d snd_soc_core.pmdown_time=1000’
    ATAG_NONE: 0 0

    Starting kernel at 0x40008000…


    Previously, i used the aicp_i9305_n-12.1-rodman01-20170419 ROM, without random reboots (not so often)

    hope this can help.

    Newbie in Android ROM.
    And many thanks for your job

    Linux User

    I think the kernel version that you have given “KERNEL m3xx/m3:4.4.4/KTU84P/I9305XXUFPB1” is not correct.

    Can you go to Settings and in About Phone see the kernel version and reply here ?
    It should be something like this: 3.0.101lineage-g5f96d9a

    Waiting for your reply !

    Linux User

    Hi shibaa987,

    Really a newbie, I am !!

    The kernel was the one provided with the ROM Lineage 14.1.20171108.nightly.i9305 ( lineage).

    I switched back to AICP 12.1 rodman01.


    Linux User

    The link for the ROM Download link  is dead. I can’t find the ROM in the menu on the left.

    Did you discontinued this ROMs or is it and error?

Viewing 10 posts - 1 through 10 (of 11 total)
  • You must be logged in to reply to this topic.