LineageOS 14.1 for HTC One M8, Nougat 7.1 ROM

GCam Port | Google Camera APK v9.2 (May 2024) Forums HTC Device Forums One M8 – m8 LineageOS 14.1 for HTC One M8, Nougat 7.1 ROM

Viewing 10 posts - 1 through 10 (of 31 total)
  • Author
    Posts
  • #16419
    Linux User
    Participant

    Hi shibaa
    thank you for your response.
    I tried Format Data end Wipe Internal Storage ecc.
    But i don’t resolved the issue.
    I see only 15GB of total memory space/disk and 4,35 GB is used from ROM and GAPPS.
    I hope that with Android 7 i can obtain more memory disk available.

    #16682
    Linux User
    Participant

    @roberto_caridi I guess it is not the ROM which is creating problem but it could be the recovery.

    First answer to some questions:
    – Which recovery are you using right now??
    – Did you re-partition before flashing the ROM??

    Possible solution(s):
    – re-partition the partition that you are seeing as reduced (/data may be) and see if you see a difference??
    – If the above does not help you then try downgrading or upgrading the recovery that you are using currently and see if you can get the storage information in the new TWRP.

    Answering few more indirect questions:

    How to re-partition in TWRP:

    Go to Wipe > Advanced > select the partition > Select Change or repair filesystem > select the filesystem you want to format in (Ext4 or f2fs are recommended)

    How to know what is the current filesystem used for which partition in the ROM:

    – The fstab file in the current system will reveal the information. Where can you find that fstab file?

    In typical Linux system the path is usually /etc/fstab
    Earlier Android version I saw it was /etc/vold.fstab
    To help you precisely I quickly logged into ADB of my Moto G and verified that the fstab file was /fstab.qcom (it was in the root directory and not in /etc)

    Read the file and you will get the filesystem details of different partitions.

    Below was the output:

    root@falcon_umtsds:/ # cat fstab.qcom
    # Android fstab file.
    # The filesystem that contains the filesystem checker binary (typically /system) cannot
    # specify MF_CHECK, and must come before any filesystems that do specify MF_CHECK

    #                
    /dev/block/platform/msm_sdcc.1/by-name/system    /system    ext4    ro,barrier=1    wait
    /dev/block/platform/msm_sdcc.1/by-name/userdata    /data    f2fs    rw,discard,nosuid,nodev,noatime,nodiratime,nobarrier,inline_data,inline_xattr wait,check,encryptable=footer

    /devices/platform/msm_hsusb_host/usb1/1-1/1-1:1.0    auto    vfat    defaults    voldmanaged=usbdisk:auto
    /dev/block/zram0    none    swap    defaults    zramsize=268435456
    root@falcon_umtsds:/ #

    I hope the above explanation helps you. If not then please revert with some more information this time (with current and previous TWRP info, screenshots etc) so that I can help you as quickly as possible.

    • This reply was modified 1 month, 1 week ago by Linux User.
    #12601
    Linux User
    Participant

    I just wanted to check and see how this was going for the m8. I tried going to the ROM download link and it doesn’t work. I’m interested in trying this out.

    #12606
    Linux User
    Participant

    Thanks to report the broken link.

    I have updated another ROM built by compuguy and also the OFFICIAL Lineage 14.1 for One M8.

    • This reply was modified 1 month, 1 week ago by Linux User.
    #13167
    Linux User
    Participant

    Tried putting the official experimental on top of CyanogenMod 14. Lineage hangs on first boot. This was using lineage-14.1-20170130-experimental-m8-signed.zip .

    #12656
    Linux User
    Participant

    Which would you recommend? Is there anything that isn’t working on these?

    #13220
    Linux User
    Participant

    I’ve flashed this ROM to my M8 phone and then flashed the gApps zip file. And now when I boot up, it says “No Sim Card – No Service”. My Sim card is in the phone, but I am not connected to TMobile.

    Please Help!!

    #13229
    Linux User
    Participant

    I figured this problem out. I had to go into my Cellular Networks and select my Network Operators and now it works!!

    #13513
    Linux User
    Participant

    I thought there is a problem in the radio.img and you need to flash that !! Thank god before that it got fixed. :)

    #13544
    Linux User
    Participant

    shibaa987,

    Thanks for the response. I am trying to go from CyanogenMod 14.1 to Lineage OS 14.1. I assume my other option would be to wipe the phone and install the Nightly if I can’t get experimental to boot.

Viewing 10 posts - 1 through 10 (of 31 total)
  • You must be logged in to reply to this topic.