Xperia Z3 LineageOS 15 Download – Android Oreo ROM

Home Forums Sony Device Forums Xperia Z3 – leo Xperia Z3 LineageOS 15 Download – Android Oreo ROM

Viewing 8 posts - 11 through 18 (of 18 total)
  • Author
  • #31786


    Xperia Z3 runs on Snapdragon 801 which is an ARM 32-bit architecture and this is a LineageOS 15 build.

    Based on the above details you need the following Oreo GApps:
    OFFICIAL ARM 32-bit Oreo 8.0 GApps or the UNOFFICIAL ARM 32-bit Oreo 8.0 GApps


    Hi shibaa987,
    I now tried ARM 32-bit Oreo 8.0 GApps in Pico-Version but I get again the ERROR 64: Wrong architecture…
    Tried with official and unofficial version.

    What am I doing wrong? I install LineageOS, then delete Cache/Dalvik and try to install GApps. But everytime I get this error message.

    Do you have any ideas for me?


    Well, there seems to be an issue on TWRP 3.1.x version which reports the following ERROR (mostly for Sony Xperia devices):
    [b]ERROR 64: Wrong architecture to set-up Open GApps’ pre-bunbled busybox[/b]

    People have reported to downgrade the TWRP to 3.0.x version and you should be able to install GApps.
    Try that and let me know.

    Cheers :)



    can you tell me which of the files on the download page is for 3.0.x ?

    Btw: I actually have installed TWRP 3.2.1-2

    Edit: I installed now TWRP from 2017-07-23 (Version 3.1.1-0) and it works fine. Could install the GApps! Thanks for all the help here.


    Sounds Great!

    This information may help other users facing the same issue.


    I’d like to go back to stock Android for Xperia Z3 but I’ve lost my backup that I did when I updated to LineageOS. Is there a possibility to go back to stock Rom?

    Already tried to install it with Xperia Companion but it says my device has an unlocked bootloader so it won’t let me install stock software in an easy way.

    Someone may help me please?


    Well, you can always flash a stock Xperia firmware using Flash Tool.

    You try to search for your Xperia Z3, if you won’t find that let me know I will help you out how to update a stock firmware or stock ROM on Xperia Z3.


    My z3 cant record videos anymore, is this a bug in the ROM? I tried different apps, but it simply sais: error when recording video.

Viewing 8 posts - 11 through 18 (of 18 total)
  • You must be logged in to reply to this topic.