LineageOS 16 for Galaxy S5

Viewing 10 posts - 21 through 30 (of 30 total)
  • Author
  • #71918

    Usually an Official LineageOS build is signed with some private keys to keep the authenticity.
    Android is being an open source codebase (hence the LineageOS is) it is possible to tamper the official builds by building it locally.

    UNOFFICIAL LineageOS builds are some clear example of this. It is not guaranteed on an unofficial build that if someone has tampered it or not.

    haggertk, being one of the directors of LineageOS team, despite an UNOFFICIAL build he signed it with LineageOS private keys to make it authentic build.

    You can visit the below link to more about authenticity of LineageOS builds:

    ? <a href="">GCam APK</a> | <a href="">Mod APK</a>


    Installed twice 1st time failed using brunowp8 ROM version, GPS Function never worked always crashed. the 2nd time well I have finally gotten my S5 to run flawlessly with everything working (yes even GPS)!

    I started off by downloading TRWP 3.22.0 then download HaggerTK’s ROM Version
    then download the GApps

    when you have those items downloaded onto your SD card simply install TWRP using Odin 3.13 if it is not installed yet


    boot into Recovery mode PWR+HOME+VolumeUP

    if installed right TWRP Recovery mode will boot instead of original Recovery mode

    go to wipe then click advanced wipe and check dalvik cache, system, data, cache (DO NOT FORMAT YOUR PHONE) Formatting erases the GPS App needed and any other Apps that your system needs in order to run programs that Android 9 does not Install

    Now Install lineageOS 16.0 and the GApps then reboot

    first thing I checked when it booted up was the GPS and it worked for me so I’m just giving friendly advice to those who are struggling with it feel free to throw some questions my way I will answer them the best I can




    The haggertk ROM is working perfectly, but the root option is not working. I tried installing addonsu-15.1, it gives me the root options of allowing app and adb, but it doesn’t actually give root privileges.


    Is there any plan from haggertk or lineage OS to release a proper rooting method for Lineage Version 16 ?



    [quote quote=64969]Great work! I now have OS16 installed successfully on my GM900I. Initially, when enabling root access from Developer Options, I could select ‘Disable’ or ‘ADB. After flashing (via Recovery/TWRP) the OS15.1, I can now select ‘Disable’, ‘Apps’, ‘ADB’, ‘Apps & ADB’. However, aftern then installing Root Checker, SU# and Titanium Backup, all three apps say that root access is not enabled, even with ‘Apps & ADB’ selected. What am I missing? Is there an for OS16 that I should be using? Thanks for any help you can provide. P.S. This project has breathed new life into my sluggish/aging Galaxy S5! 🙂[/quote]


    Have you succeed in rooting your phone?


    No. I have now reflashed official 15.1 and have this version rooted.




    Anybody got usb 3.0 working in lineage OS? Quick search on google didn’t hit anything.



    i have upgraded my S5 KLTE (900F) successfully with the February haggertk Build , but the Lineage Updater cant find updates?

    please help.




    I would like to install LineageOS 16 on my SM-G900A (AT&T version of the S5). I was told in another forum that this is not possible. Can someone here help me with a definitive answer?






    Howto raise a feature request to have ANT+ enabled on LinageOS 16 builds for the klte of haggertk?

    ANT+ was working on Stock-ROM and it’s not unknown to LinageOS – some Lenovo devices has it enabled.

Viewing 10 posts - 21 through 30 (of 30 total)
  • You must be logged in to reply to this topic.